Archive for the ‘ Server ’ Category

[转载]平民 RAID 架设与评测

本文是截取自 PC ADV 电脑王第 49 期 (2008年8月) 的 “平民 RAID 架设与评测” 文章,这是一本不错的杂志,完整的内容建议大家可以去买来阅读。
Read more

phpMyAdmin 的设定值

phpMyAdmin 应该是大家最常用的 MySQL 数据库管理套件,如果要修改它的默认值,请编辑 phpMyAdmin 目录下的 “config.inc.php”,以下列出一些我建议修改的参数:
Read more

使用 .htaccess 自订“404 找不到网页”的页面

一般我们租用的虚拟主机无法让我们修改 httpd.conf,所以只能透过使用 .htaccess 来自订“404 找不到网页”的页面。

Read more

从 Blogger 转移到 WordPress 的技巧

本站已经由 GoogleBlogger 转移到 WordPress,这是转移到 WordPress 之后的第一篇文章。

用过 WordPress 之后才知道 WordPress 的好,WordPress 相对于 Blogger 的优点如下:

  1. 标签云、搜寻、继续阅读、最新文章、最新留言、分页…等等基本功能,已经内建在 WordPress 里了,不需要辛辛苦苦去改范本、研究程式码,而 Blogger 往往因为手动加了这些功能,而变得极为拥肿。
  2. 可以上传图片、影片、音乐…等档案,以往这些在 Blogger 里,都需要再寻找额外的网页空间存放,并且 WordPress 上传的图片会自制缩图。
  3. 对于读取权限的控管,WordPress 可以做到完全公开、公开给特用用户、单篇密码保护、禁止搜寻引挚、完全隐藏。
  4. WordPress 已经内建几个知名部落格系统的转移工具,当然包括 Blogger。
  5. WordPress 同时有免费线上部落格(BSP)部落格架站程式
  6. WordPress 的布景主题(Themes)更多、更漂亮。
  7. 琳瑯满目的外挂程式,很难找不到你想要的功能。

Read more

设定 Linux 桌面的萤幕分辨率

1. [系统] -> [管理] -> [显示] (或执行 /usr/bin/system-config-display):

到 [硬件] 页签,选 “Generic LCD Display”下的“LCD Panel 1024×768”,按 [确定]。

再回到 [设定] 页签,选分辨率为 1024×768 -> [确定]

2. [系统] -> [偏好设定] -> [萤幕分辨率] (或执行 /usr/bin/gnome-display-properties):

设分辨率为“1024×768”,更新频率设为“60Hz”。

增加 ssh 的安全性设定

编辑 /etc/ssh/sshd_config,加入或修改下列参数:

#禁止 root 以 SSH 登入
PermitRootLogin no

#仅允许特定群组登入
AllowGroups group1 group2

#仅允许特定帐号登入
AllowUsers user1 user2

#禁止使用空白密码登入
PermitEmptyPasswords no

#限定只能使用 SSH2 协定
Protocol 2

#限定最多可以同时连线的数目
MaxStartups 5

vi 与 vim 的指令整理

vi 是 unix 家族下最功能强大的文字编辑器,让用户只要使用一个键盘就可以完成所有的编辑。而 vim 则是 vi 的加强版,甚至在 Windows 上也找得到 vim 的芳踪。但 vi/vim 众多的指令却经常令初学者却步,它的指令还有分大小写,以下就是我所整理出来那些令人却步的指令:

(每一列前面若有 * 表示为常用的指令)
Read more

在 XWindow 安装及变更新字型

安装新字型

  1. 将新字型(*.ttf, 例如:微软正黑体)复制到 “/usr/share/fonts/zh_TW/TrueType/”。
  2. 执行
    fc-cache -f -v

    更新系统字型资料。

变更 XWindow 的字型

  • GNOME:到工具列的 [系统] → [偏好设定] → [字型] 做变更。
  • KDE:到 [控制中心] 的 [外观&主题] → [字型] 做变更。

SVN + Trac + Apache 完整安装攻略

SVN + Trac + Apache 完整安装攻略,而原本在 SVN 所欠缺的用户及权限管理接口,也都可以由 Trac 的外挂程式来搞定,可谓两全其美。

本文章适合熟悉 SVN 但没用个任何线上专案管理的人做为参考。

请注意,本人使用的 Linux 是 CentOS 4.x,RHEL 4.x 也适用。

Read more

Apache 1.3.x 限制频宽(mod_bandwidth)

仅限 Apache 1.3.x 使用 mod_bandwidth 来限制用户流量。

Read more

return top